I received an email from a fellow amateur radio operator. He had purchased an
FT301D used and it has a display problem. I have decided to write some information
about how to sort this problem or problems out. -- article written 30 May 2013
From: Edga
To: earlinclayton@yahoo.com
Sent: Tuesday, May 28, 2013 2:17:31 AM
Subject: FT-301 display issue

Earl

I saw your website and decided ti write.  I have an FT-301SD radio and the digital display isn't working correctly.  My display LED's work but it shows the wrong
frequency.  For example on 10m's the radio shows 2F.000 instead of 28.300 but on 15m's it will show 21.300 which is fine but if you jump to 20m's the display
will read 34.300 and not 14.300 and on 40m's the display shows 37.300 and not 7.300.  If I go to 160m's its all zeros I think.  The person I got this radio off of 2
years ago had an Crystal in it for the CB frequencies. What can I do to get my radio to display the proper frequency? I do know what frequency I am on when I
use the radio but it would be great to have my rt working correctly.  Everything else seems to be working correctly and it has the amp on it too.  I hope to hear
from you and I hope this is something that can be fixed.  This s my first and oly radio at this time and its a great radio and I am always getting compliments about
it except i'd like my display to work the right way.  Thank you for your time and help.

73's
Edgar
KD8xxx (identity protected)

Sent from Galaxy S3

Earl

When I got the radio it was working the same as described.   I was new to the hobby and wasnt 100% suee about the radio and I got it anyway because I wanted
a radio bad.  The previous owner was a big CB'er before getting licensed.  I look forward toward any help you can provide and will be waiting for an update and
keeping an eye on your website.  Thank you for come back so quick to me question.

73's
Edgar
KD8xxx (identity protected)

Sent from Galaxy S3

On May 28, 2013 10:47 AM, "Earl Andrews" <earlinclayton@yahoo.com> wrote:




Hello Edgar. The problem can be a bit complex. Was the radio ever working correctly? If you bought it

and it has this problem ..then it could be the result of modifications that someone made to the radio.
Modification Possibility nr. 1----> A voltage dropping diode could have been inserted in the 5 volt line running to power the FT301 displays. If the displays
(TIL 306s qty 3 of them each and TIL308s) are strong..they can run fine on 4.4 volts or so. This mod is listed on the internet for the FT301 displays. I have done
it myself on a couple of FT301Ds. -- It worked fine on one FT301 but on another (with displays that were starting to fail) ..it made the display frequency worse.

Modification Possiblity nr. 2----> The first two numbers of the display are "set" by a diode matrix. In other words..the bandswitch selects these diodes to
display 28 on 10 meters   21 on 15 meters 3 on 80 meters ect. ---->> I have never really worked on this display matrix and I dont know all that much about
it..because.. IF there is a problem with the display-- (in the past)..I have either junked the radio for parts sell off.. or..I have bought an AADE digital display
kit and performed the installation of the AADE display. I have had good luck with the AADE display for the FT301.

NOW..someone could have been mucking about trying to get the CB bands on certain portions of the 28 and 29 mhz bands and he/she could have screwed up
the diode matrix assembly--
AND/OR... another possibiltity is the bandswitch is oxidized and causing problems. Perhaps cleaning the wafer switch contacts with
a quality contact cleaner might do the trick.

Another thing that can happen is the wafer switch contacts become a bit loose and poor contact is being made. I had this problem with an FT101E I was working
on. By gently probing the wires connecting to the wafer switch..I found which wires and connections were causing the problem..(using gentle hand/insulated
probe)..and I found by settling the wires in a certain position the problem was solved (at least for the time being).

NOW: Murphys Law: anything that can go wrong..will go wrong. -- maybe all at once or intermittently!!!! -- Some or all of the above factors could
be true..but as well:
the displays themselves might just be failing. --- What I would do..is bite the bullet now and install an AADE display (liquid crystal display).
It is both accurate and attractive and it does not burn out like the old TIL306s and 308s.

NOTE: I was selling the display parts (TIL306s and 308s) at about $8 to $10 each..used and tested..but I am now sold out. Im also pretty well sold out of crystals
and rubber feet and chasis lids and other mechanical parts (ie knobs). I still have 3 junked FT301s around here with various parts and Ive gone out and bought
some of the semiconductors and discontinued ICs..ie the TA7089M. \
I have one good working FT301 with the AADE display and one good working FT301 analog version.



It can be corrected..but you have to try a few different things and check for a few different things..and right now..

Im heading up to the cottage lot to do some work..so I will have to write these things up and perhaps I will

write a small article for my web page tonight and tommorrow night and give you the answers that way.

The display parts are TIL 306s and TIL308s. Generally..these display parts (seven segment displays) are

very expensive to buy. They burn out with time. The segments burn out one segment at a time and that can

create some odd looking display frequencies. But..could also be the result of the previous owner playing around

with the "diode matrix"which controls the first two display nrs.

So..I will write up the situation in the next day or two..when I have some spare time and I will make a small

techical article for you and other FT301 owners. -- I will write you back soon. 73 earl ve3ab
2 pictures of an FT301D with display problems. Note: The previous owner had
used adhesive copper tape of some sort. This was intended to draw heat away
from the TIL 306s and TIL 308 display parts.

Heat is the big enemy of these displays. The TIL 306s and TIL 308s are seven
segment displays and driver chips all in one and were discontinued from
manufacture years ago. Originally ..the parts were mid 70s and early 80s
vintage. They are expensive to buy ..unless you happen to find some at an
electronics estate sale or something.

A far better solution is to install the AADE display. Below is my radio with the
green display. The display I installed is not backlit. I wish I had bought and
installed the backlit display.

I am in the process of reworking my AADE installation. Too many other projects
on the go..however..and very little time.

Spring is here and yard work/cottage lot work and fishing are some outdoorsy
things I do in the warmer months! -- Winter up here in Northeastern Ontario is a
6 month snowy cold affair. That is when I hunker down in my basement shop
and do alot of these unfinished projects.

My new outdoorsy web site is www.earlandrews.info and you are welcome to
look at it as well.
this article is under construction..(end of May 2013)..

I will be adding a bit more to it..(in particular.. concerning how seven
segment displays actually work.. 73 earl ve3ab